I receive an error message “Failed to connect to the update service”, how do I download the latest version of e@syFile™ Employer?

Where you receive the “Failed to connect to the update service” error message, you will be required to download and install (re-install) the latest version (6.5.0) of e@syFile™ Employer.

The latest version (6.5.0) can be downloaded from  e@syFile™ the guide or SARS eFiling and clicking on     
 

print this page
SARS eFiling eFiling Login eFiling Register Now eFiling Forgot Password eFiling Forgot Username E@syFile
FIND A PUBLICATION
FIND A FORM
FIND AN FAQ